Cyberpunk 2077: Mod brings support for AMD FSR 2.0

Cyberpunk 2077: Mod bringt Unterstützung für AMD FSR 2.0

Cyberpunk 2077 (test, patch test 1.5) provides ray tracing, Nvidia DLSS and AMD FSR 1.0, but not the greatly improved 2.0 of its open source AI anti-aliasing software. With the Ministry you want French fries 1337 Change that now – and replace the DLSS program library.

FSR 2.0 enhances image quality in Cyberpunk too

Cyberpunk 2077 requires very fast hardware, especially when running high screen resolutions and ray tracing. It is then that turning on the Rise Technique becomes somewhat mandatory. But while DLSS is available for gamers using Nvidia’s RTX graphics cards, owners of the AMD graphics accelerator are so far left with FidelityFX Super Resolution 1.0. On the other hand, FSR 2.0 achieves significantly superior image quality in other games using a temporal component, which can certainly come close to the DLSS model, as ComputerBase was able to find out in three comparative tests.

The dystopian futuristic role-playing game does not officially support the anti-aliasing that was introduced in early 2022; There has also been no similar announcement from AMD or CD Projekt Red yet. French fries 1337 He wasn’t happy with the situation and has now released a mod to Nexusmods that replaces DLSS with FSR 2.0, as it was initially Video Cards mentioned. Two screenshots show a drastic improvement in image quality compared to the current FSR 1.0 implementation, and the frame rate with the GeForce GTX 1080 has doubled compared to the original UHD resolution, according to the designer.

FSR 1.0 with the same settings

Compare photos: FSR 2.0 balanced with enlarged graphics settings (Photo: Nexusmods) FSR 1.0 with the same settings (Photo: Nexusmods)

It has the source code to edit French fries 1337 Posted on github. The project is still under development, but it seems to be working already. The mode is now also executable on Steam platforms with Linux, after getting rid of the initial issues with Proton.

DLL file sharing makes it possible

The technical implementation is based on the similarity of DLSS and FSR 2.0. Either way, these are temporal expansion algorithms that must be fed with comparable data. Since Nvidia publishes DLSS versions as dynamic software libraries, the corresponding DLL file can be exchanged – for example, I already used this DLSS Swapper tool. However, in the case of Cyberpunk mod, not the official Nvidia DLL is used, but a specially modified version that translates between DLSS and FSR 2.0.

To install the mod, users have to share a total of three DLL files and modify the registry. This leaves no trace in the game menu, because DLSS must be activated after that in the settings – the name is deceptive, because behind it is FSR 2.0. The modding methodology applied also represents the ability to retrofit FSR 2.0 to other games with DLSS support French fries 1337.

DLSS is still in settings
DLSS is still in settings (Photo: Nexusmods)

The mod does not represent FSR 2.0

However, the whole thing is not without limitations. The developer himself notes that the situation is not close to the quality that CD Projekt Red and AMD can achieve with the official implementation of FSR 2.0 – on the one hand because the project is not yet fully developed, but on the other because it has a complete implementation that is not at all possible. In addition, the usual hints for such mods apply: graphic bugs and game crashes are the order of the day. Some graphics settings conflict with the mode, requiring frequent restarts. The modr also warns against increasing shadows.

Is this FSR 2.0 a native implementation by developers? No, I’m describing this situation as a hack for a reason. There are some things in FSR 2.0 that I haven’t implemented yet (or can’t do at all) that will greatly improve image quality. Let’s hope CDPR eventually adds FSR 2.0 themselves.

I am using DLSS. Do I have to download this mod? No need for that. The included DLSS version does much better than this hack. I made this for people who have incompatible GPUs and need to resort to FSR 1.0.

French fries 1337

So it is not surprising that French fries 1337 We advise owners of an RTX graphics card not to install it: it is recommended to use the official DLSS application, which significantly outperforms the mode. The mod is only intended for gamers with AMD or older Nvidia graphics cards who can’t use DLSS – even if the specific implementation doesn’t represent the actual performance of FSR 2.0.

See also  Once again we move to Vodafone

Leave a Reply

Your email address will not be published.